#1 25-05-2011 18:16

jb
Inscription : 25-05-2011
Messages : 5

Collection personnalisée non reconnue

Bonjour,

Pour tester Gcweb, j'ai créé une collection personnalisée sous gcstar(1.6.1) , je l'ai exportée et ai mis le .gcs et le dossier des images dans collections du site.

Le config.php se lance, trouve la collection, mais à la sauvegarde, j'ai le message en rouge:

Attention : Le model de collection inline est inconnu de GCweb. Veuillez copier modèle de collection GCstar dans le dossier /conf/GCmodels/ de GCweb et réenregistrer cette page.

J'ai envoyé par ftp le .gcm sur le site dans conf/GCmodels et cela ne change rien.

Qu'ai-je raté ?

Merci.

Dernière modification par jb (25-05-2011 18:17)


J.Bratières

Hors ligne

#2 25-05-2011 23:04

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

Bonjour,

As-tu réenregistrer la page de config de gcweb ?

Quel version de GCstar ?

Hors ligne

#3 26-05-2011 08:22

jb
Membre
Inscription : 25-05-2011
Messages : 5

Re : Collection personnalisée non reconnue

Oui, c'est en cliquant sur le 'sauvegarder' de la page du config.php qu'apparait le message d'erreur.
Gcstar 1.6.1


PS: le forum ne marche pas bien sous Opera (et notamment le Captcha).


Merci.


J.Bratières

Hors ligne

#4 26-05-2011 21:59

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

oups ... je voulais dire version de GCweb, trunk ou dernière realase stable ?

Merci pour le captcha, je vais regarder pour changer ce dernier et en mettre un plus "normal"

Je t'envoie un mail, merci d'y repondre en y joignant ton fichier gcm

Dernière modification par jonas (26-05-2011 22:05)

Hors ligne

#5 27-05-2011 11:34

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

[edit]
Dans le fichier *.gcm que tu m'as envoyer le type de collection est "essaie", dans le *.gcs "inline". Es-tu sûr d'avoir envoyer le bon *.gcm ? n'en aurais-tu pas un avec comme contenu

<?xml version="1.0" encoding="UTF-8"?>
<collection description="???" name="inline">
...

?
Non après relecture du code je ne pense pas, lire la suite big_smile
[/edit]

Aurais-tu renomer le fichier gcm ?

[edit]Par contre je remarque que maintenant je dois pouvoir simplifier le support des collections perso (l'utilisateur n'aurais plus besoin de copier de *.gcm). Je regarde et te rien au courant.
Finallement non sad[/edit]

Un petit chose pour information, je remarque de ta collection contient de nombreuses images ! Le générateur pour collection perso de GCweb n'est prévu que pour une voir deux images !
Pour afficher plus d'images il faudra reprendre le code "à la main", quelque connaissance en php sons requise pour cette tâche mais rien de bien méchant.

Dernière modification par jonas (27-05-2011 12:05)

Hors ligne

#6 27-05-2011 12:06

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

Bon avec tous les edit mon message précédent n'ai plus très claire big_smile

Je résume donc :
  - Aurais-tu renomer le fichier gcm ?

Une petite chose pour information, je remarque de ta collection contient de nombreuses images ! Le générateur pour collection perso de GCweb n'est prévu que pour une voir deux images !
Pour afficher plus d'images il faudra reprendre le code "à la main", quelque connaissance en php sons requise pour cette tâche mais rien de bien méchant.

Hors ligne

#7 27-05-2011 13:43

jb
Membre
Inscription : 25-05-2011
Messages : 5

Re : Collection personnalisée non reconnue

ben, non je ne pense pas avoir renommé ce fichier.

Pour les images, en réalité il y en a plus, cela n'était qu'un essai. Je ne connais pas gd chose au php, mais je regarderai.

Merci de te pencher sur mon problème.


J.Bratières

Hors ligne

#8 29-05-2011 17:13

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

Tu n'as pas renomé le fichier dis-tu hmm cella me semble bizarre.

Vérifie que dans gcstar tu n'as pas un inline.gcm
  - Si oui copie le dans gcmodels de gcweb
  - Si non renomme ton fichier en  "inline.gcm" dans gcmodels de gcweb.

Hors ligne

#9 30-05-2011 12:12

jb
Membre
Inscription : 25-05-2011
Messages : 5

Re : Collection personnalisée non reconnue

Bonjour,

Je ne pense pas l'avoir renommé.

Ceci dit, c'est vrai que j'ai fait tellement d'essai avec ....
Je n'ai aucun inline.* sur mon poste.
Je vais refaire un truc neuf à partir de zéro.

Je tiendrai au courant.

Peux-tu m'en dire un peu plus sur le nombre d'images, car dans la vraie collection j'en ai une vingtaine par objet.

Merci.


J.Bratières

Hors ligne

#10 30-05-2011 21:33

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

Pour les images, ce qu'il faut savoir c'est que le 1er type de collections supporté par GCweb était celle le livre. Les collections de livres dans GCstar un 2 images (couverture, et dos) pour le générateur c'est rester (ce qui convient très bien pour le films, comics, jeux video ...)

Dans ton cas ce que je te conseille de faire c'est de ne mêtre QU'UNE images, ensuite par copier coller et un peux de bidouillage tu arriveras à mettre d'autres images sur une même page en éditant le fichiers de collection (qui se trouve dans gcweb/themplates/default/<type page>_<type collection>.php)

Hors ligne

#11 27-12-2014 18:56

jb
Membre
Inscription : 25-05-2011
Messages : 5

Re : Collection personnalisée non reconnue

Bonjour,

J'ai été occupé à d'autres choses et me remets seulement maintenant au problème.
J'ai créé une bête collection de livres (non personnalisée donc), avec un livre une image.
J'ai décomprességcweb 1.2, copié le .gcs et le dossier image dans collections.

En me connectant au site j'ai "Fatal error: Call to undefined function: scandir() in /mnt/159/sdb/b/7/j.bratieres/TMP/GCWEB/inc/render.php on line 39"
Les fichiers sont bien là, il n'y a pas eu d'erreur au ftp.

J'ai sauvagement mis les protections à 777 partout, cela n'a rien changé.

Qu'ai je oublié ?

Merci.


J.Bratières

Hors ligne

#12 26-03-2015 21:19

jonas
Administrator
Inscription : 25-06-2006
Messages : 727

Re : Collection personnalisée non reconnue

Bonjour

Désolé de la réponse très tardive mais je n'ai pas vu arriver le nouveau message.

Quel est votre version de PHP ? <5.4 ? (j'ai l'impression que c'est de là que vient le problème http://php.net/manual/en/function.scandir.php)

Hors ligne

Réponse rapide

Veuillez composer votre message et l'envoyer
Si vous êtes un être humain ne changez pas le contenu de ces deux champs.

Pied de page des forums